Stampa post Stampa post
Home » How To
Cambia categoria:

Categorie


IE10, CSS e i font personalizzati: non funzionano

  • Condividi su WhatsApp
  • Consiglia su Facebook
  • Condividi su Facebook
  • Condividi su Twitter
  • Condividi su LinkedIn
  • Condividi su FriendFeed
  • Condividi su Pinterest
  • Pubblica su MySpace
  • Invia su Segnalo
  • Invia a Diggita
  • Segnalibro su Google
  • Pubblica su Blogger
  • Condividi su Google Reader
  • Condividi su Google+
1 marzo 2013 - 18:21 | Letture 435 | Commenti 1 | Link breve

E anche stavolta Microsoft qualcosa ha combinato. Fino alla versione 9 di Internet Explorer tutto bene con i font custom, dalla 10 siamo daccapo: non funzionano.


Internet Explorer aggiornato, guaio combinato.

Internet Explorer aggiornato, guaio combinato.

Dico io: è mai possibile che Microsoft non ne imbrocca mai una al 100 per cento? Da poco, come abbiamo visto, Internet Explorer 10 è stato messo a disposizione anche per chi utilizza Windows 7.

Peccato che, se lo si installa, ci sono eccellenti probabilità che se il vostro sito o blog impiega font personalizzati, questi non saranno visualizzati e al loro posto si vedranno i font dichiarati “in seconda battuta” o, peggio, quello di default.

Cercando IE10 CUSTOM FONTS il primo risultato è una lamentela

Cercando IE10 CUSTOM FONTS il primo risultato è una lamentela

Va bene che ancora è una “RTM” (Release To Manufacturer, ma è praticamente definitiva), comunque ho subito pensato a un mio problema, almeno per quanto concerne questo blog, ma a quanto pare così non è: facendo qualche ricerchina mi pare proprio di non essere il solo.

Le soluzioni proposte (ad esempio questa e questa), nel mio caso non sembrano funzionare, come si vede dall’immagine in testa che riprende sopra IE9 e sotto IE10, stesso snapshot ripreso dopo l’aggiornamento.

Inutile precisare che le mie impostazioni funzionano perfettamente con:

  1. Internet Explorer fino alla versione 9 compresa (e si vede da sopra)
  2. Firefox (su tutti i sistemi, da sempre)
  3. Chrome (su tutti i sistemi, da sempre)
  4. Safari (su tutti i sistemi, da sempre)
  5. Opera (su tutti i sistemi, da sempre)

Mi riesce quindi difficile credere che “dipenda da me”. Piuttosto, Microsoft deve aver cambiato ancora una volta le carte in tavola a proposito della gestione dei font.

Ovviamente non finisce qui, prima o poi il problema si risolverà. Ma, mi domando, quando diavolo si deciderà Microsoft a fare le cose perbenino, come fanno tutti gli altri? Già il fatto che nei fogli di stile ancora sia necessario un “<!–[if IE]>” mi pare alquanto anacronistico (per essere gentili), ma che ancora serva anche con la versione 10 è davvero ridicolo.

Poi non si lamentino se le quote di adozione del suo browser calano.

Marco V. Principato (1127 Posts)

Informatico sin dal 1980, ha quasi sempre svolto questa attività sia nella Pubblica Amministrazione che fuori. Ora libero professionista e laureando in Scienze della Comunicazione, si dedica alla donna della sua vita, ai suoi hobby e ai suoi siti.




Etichette: ,


COMMENTI (locali)

Lascia un commento (locale)

Aggiungi di seguito il commento, oppure trackback dal tuo sito. Puoi anche abbonarti a questi commenti via RSS.

Sii gentile. Massimo 1 link o sarà moderato. Pulizia nel testo e rimanere in tema. Niente spam, per favore.

Puoi usare questi tag:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

*

COMMENTI (Facebook)